node_modules不上传服务器导致网页无法打开,提示找不到对应的模块

这几天在做一个简单的文本编辑器,用到时simditor这个框架,使用npm安装后会增加几个对应的模块,但是这是在本地的,我往公司服务器上传代码后后台就不能正常跑起来了,因为node_modules不受版本控制的,而正式服务器上又不会自动安装这些模块.所以这个应该怎么解决呢??——ios学前端的小白- -!

node_modules只在本地使用,有些模块会根据系统版本,nodejs版本而安装不同的模块,所以你要做的就是将node_modules文件夹移出工程目录,然后上传工程目录(为了提高上传速度,反正传上去也要删掉),然后在服务器上再次npm install一次

npm使用package.json这个文件来声明项目的依赖的。

1、假设项目下已经有package.json这个文件

那么,在安装simditor的时候,可以加上--save,把simditor自动添加到package.json文件里

npm install simditor --save

然后,你会发现package.jsondependencies字段内容多了个依赖。
到了正式服务器,在项目路径下,运行npm install,就会下载相关的依赖了。

2、假设package.json文件还不存在,那么,先运行下面命令创建一个。创建完后,参考之前的步骤

npm init -f

备注:非必要,不要把node_modules纳入版本控制。

发表评论

电子邮件地址不会被公开。 必填项已用*标注