Dingo api安装不上-lumen下安装

lumen是5.2.7
lumen根目录>composer require dingo/api:1.0.x@dev

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies including require-dev
Your requirements could not be resolved to an installable set of packages. Problem 1
    • Conclusion: dont install dingo/api 1.0.x-dev

    • Conclusion: dont install dingo/api v1.0.0-beta3

    • Conclusion: dont install dingo/api v1.0.0-beta2

    • Conclusion: remove illuminate/container v5.2.32

    • Installation request for phpdocumentor/reflection-docblock locked at 3.0.
      2 -> satisfiable by phpdocumentor/reflection-docblock[3.0.2].

    • Installation request for dingo/api 1.0.x@dev -> satisfiable by dingo/api[1
      .0.x-dev, v1.0.0-beta1, v1.0.0-beta2, v1.0.0-beta3].

    • Conclusion: dont install illuminate/container v5.2.32

    • dingo/api v1.0.0-beta1 requires illuminate/routing 5.1.* -> satisfiable by

      illuminate/routing[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25,
      v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].
    • illuminate/routing v5.1.1 requires illuminate/container 5.1.* -> satisfiab

    1. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v
      5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.13 requires illuminate/container 5.1.* -> satisfia

    2. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.16 requires illuminate/container 5.1.* -> satisfia

    3. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.2 requires illuminate/container 5.1.* -> satisfiab

    4. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v
      5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.20 requires illuminate/container 5.1.* -> satisfia

    5. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.22 requires illuminate/container 5.1.* -> satisfia

    6. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.25 requires illuminate/container 5.1.* -> satisfia

    7. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.28 requires illuminate/container 5.1.* -> satisfia

    8. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.30 requires illuminate/container 5.1.* -> satisfia

    9. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.31 requires illuminate/container 5.1.* -> satisfia

    10. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22,
      v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.6 requires illuminate/container 5.1.* -> satisfiab

    11. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v
      5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • illuminate/routing v5.1.8 requires illuminate/container 5.1.* -> satisfiab

    12. by illuminate/container[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v
      5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].

      • Can only install one of: illuminate/container[v5.1.1, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.13, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.16, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.2, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.20, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.22, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.25, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.28, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.30, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.31, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.6, v5.2.32].

      • Can only install one of: illuminate/container[v5.1.8, v5.2.32].

      • Installation request for illuminate/container locked at v5.2.32 -> satis

    13. by illuminate/container[v5.2.32].

    Installation failed, reverting ./composer.json to its original content.

    同样的问题,求解答

    发表评论

    电子邮件地址不会被公开。 必填项已用*标注